In theory RAIDs help protect your data; however, if another disk fails, you can't complete a rebuild on an already weakened disk (a build that has been compromised), or your controller fails along with the entire array then the data will usually be available but will have to be rebuilt properly away from the failed piece(s) of hardware. We perform all types of RAID recovery and controller failures for businesses located in Belfast and throughout Northern Ireland at our facility.
If a RAID fails, do not attempt to start a rebuild or allow the controller to re-initialise the RAID. Forcing a rebuild or allowing the controller to re-initialise the RAID and rebuilding the RAID onto a failing disk is the number one reason why we see permanent data loss from failed RAIDs. Make sure to note which disks were in what positions prior to failure. Do not continue to swap or re-seat disks. Shut off the array and allow us to create an image of each disk prior to anything being written back into those disks.
RAIDs can fail in multiple layers: a failed disk, a failed rebuild, a failed controller. These are some of the most common failures we experience when recovering RAIDs.
We have recovered all types of RAID levels (from RAID 0 through RAID 60), from every type of controller and each platform type: hardware RAID cards, motherboard RAID configurations & software-based RAIDs using mdadm and Storage Spaces etc., in NAS devices, server environments, workstation environments, etc.
We have recovered data from RAID 0, 1, 5, 6, 10, 50 and 60 configurations, along with JBOD configurations, from a variety of RAID controllers including but not limited to Dell PERC, HP Smart Arrays, LSI MegaRAIDs, Adaptec, Areca, Broadcom & other RAID card manufacturers, as well as motherboard based RAID setups, software-based RAID systems such as those created using mdadm and Storage Spaces, in NAS units, servers and workstations.
One of the reasons RAID 5 is dangerous is because of how the data is written across multiple disks. With RAID 5, data is written with a parity block that spans across every disk in the RAID set. If a single disk fails within the RAID set, you can continue to run the system. However, since this also means the RAID system will continue to operate even when a single disk fails, many users don't notice that their RAID system is operating at less than full capacity until a second disk fails. Once a second disk fails while the first disk is still being rebuilt into the new RAID configuration, the entire RAID set will fail. Most requests for data recovery from RAID 5 that we receive are caused by one of these three scenarios: A.) Failed Rebuild: The user attempted to perform a rebuild of their failed RAID set after the loss of a single disk and they were unable to complete the rebuild process. B.) Controller Failure: In some cases, the RAID controller may become corrupted and/or lose its configuration information resulting in an inability to access or rebuild the RAID set. C.) Second Disk Failure: While running with a previously failed disk in a RAID 5 configuration, another disk in the same RAID set fails causing the entire RAID set to fail.
In addition to the rebuild process being a risk for larger RAID 5 configurations because it requires reading every sector on all of the remaining members, there is also a significant probability with large storage capacities that during the rebuild process the controller will encounter an unreadable sector. If this happens to occur while the rebuild process is ongoing, the controller may mark a second disk as "failed" and cause the entire RAID 5 configuration to go offline. Because of this possibility, any degraded RAID 5 configuration containing critical information should immediately be shut down rather than attempting to rebuild the configuration onsite. This will eliminate the possibility of further reducing the chances of successful recovery.
Each member in our RAID 5 laboratory data recovery is always cloned prior to beginning work on the data. Each disk is cloned using a sector by sector image transfer, which means no additional stress is added to any failing components. Before cloning, each failing component is isolated and repaired, either at the head, circuit card, or firmware level depending upon the nature of the failure. Once cloning is complete, we determine the logical structure of the RAID 5 configuration based upon the clones of each individual member. Using the information we obtain from analysing the clones of each member, we create a virtual copy of the original RAID 5 configuration, including any necessary rebuilds using parity values calculated across multiple sets of clones. When we have determined the correct parameters for recreating the original RAID 5 configuration, the files contained within the file system become available again. Whether the original physical RAID 5 configuration still exists or not does not matter. We have done exactly this on a Dell PowerEdge on SCSI disks, an IBM SAS array, and an HP array that wouldn’t boot after a ‘successful’ rebuild.
RAID recovery isn't repairing an array, it's rebuilding it. In other words, we read each individual disk separately, determine how all disks were configured together in the RAID and rebuild it using only read-only copies of those disks; therefore, a bad rebuild or dead controller can't damage it further.
We identify which disks are bad; find the RAID level (if any); identify the controller; identify your disk configuration and layout. We determine what failed first and in what order. Then we'll provide a written price quote.
Each failing disk is repaired or copied first (heads, board or firmware) before any other disks are used in the recovery process, so no disk is put under strain.
Once each of your disks has been copied (as a read-only image) all further work will be completed using the copy as opposed to your originals. Thus your original disks will remain unchanged in their configuration.
The actual disk order, block size, parity and rotation are determined from the copies made of each image, and the RAID is assembled virtually (at whatever RAID level).
After successful assembly of the RAID, the file system is repaired and the individual volume(s), database(s), VM(s) and file(s) are extracted from the RAID, organised and named.
Prior to returning any recovered data to you we check to ensure the recovered data can open and function correctly. We will also allow you to review the results of our recovery efforts prior to transferring the data.
The recovered data will be provided to you either through a new, fresh drive (which will be equal to the amount of data recovered), or via secure transfer method, depending upon how best suited for you.
We recover all types of RAID configurations (RAID 5 with two bad disks, failed rebuilds, dead controllers, reinitialised arrays, etc.) using our ability to rebuild the RAID from read-only copies of the disks (never putting original disks under stress).
Give us some information regarding what happened to cause this issue, and an engineer will contact you. Usually within a single business day.
We will get back to you soon. If it is urgent, call 028 9002 0144.
Before we do any work, you receive a complimentary diagnostic, followed by a fixed price quotation for the project. RAID recovery services begin at £500 + VAT. This applies to both single mirror RAID 1 and multi-disk arrays (RAID 5, 6, 10, 50 and 60). All quotations are based upon each individual project. In most cases you will only pay if we recover your data; however when the disks require physical repairs (parts and bench time) we request a 50% deposit which can be applied against your final payment when we have recovered your data.
Examples of RAID arrays that we have retrieved, showing some of our recovery experience with different fault conditions and configurations. Customer information remains confidential.
One of the disks that were part of the RAID was dead for weeks before anyone noticed it; the second was also starting to fail. So we simply imaged the readable disks and put them back together again by rebuilding the RAID so that we could recover the lost files.
The PERC card had failed and the array would not assemble. In this case, instead of using the PERC card (which is hardware), we took images of the disks and created the RAID in software, then rebuilt the RAID 10 to recover the information.
Because two rebuilds onto weak disks caused damage to the parity of the RAID, we ended up having to image all twelve disks and rebuild the RAID from those images in order to recover the volume.
A disk failure combined with a corrupted file system made the volume drop. To recover the shares, we imaged the disks, used the images to build a new RAID off the box and recovered the shares.
There were bad sectors on both of the mirrors but they were located at different points. We imaged each mirror, joined the good parts together and recovered 100% of the data.
Although a new array had been created, the majority of the files were recovered using the original file system.
Send or drop off your item for a free diagnostic check with a description of the issue. One of our engineers will review the item, then provide you a written quote prior to doing any repairs.
Prior to posting the disks to us or dropping them off personally, please get a quote from us by phone or via the quotation request form. The first step in this process is to remove the disks from the array’s server or enclosure, even if you are dropping them off in person. If you are posting them, make sure they are packaged securely, include your contact information, and send them to us. Our diagnostic service is complimentary, and after receiving your disks and performing the diagnostic analysis, we will provide you with a firm written cost for our services prior to accessing a single sector.
Sending it? The use of a tracked, insured delivery method would be recommended. Alternatively, dropping it off can also be done Monday to Friday, 9am–5:30pm; no prior booking required but do ensure that all items are packed accordingly.
Still waiting to send something? Please complete the form describing the failure/fault in your own words and one of our engineers will get back to you with a quotation based upon your individual circumstances.
We will get back to you soon. If it is urgent, call 028 9002 0144.
While we recover RAID arrays at every possible level, there are two levels that are worth mentioning separately. RAID 0 does nothing but spread data across multiple drives with no redundancy. If any of those drives fail, then everything is lost. However, when brought into the lab, each drive is copied individually, including the drive that has failed. Once all of the drives are copied, the stripe is reassembled from the individual drive images. RAID 5 is slightly different as it allows for one drive failure without losing access to the data. It is also slightly deceiving because once the failed drive is replaced, and the array begins to rebuild itself under load, another failed drive could cause additional loss. In cases such as these, it would be best to shut down the array immediately and image all of the drives rather than attempting to rebuild it within itself. Similarly, RAID 6 and RAID 10 operate in much the same way, and therefore require that all members of the array be imaged prior to attempting to restore any type of logical structure to the array.
These are some of the most frequently asked RAID recovery-related questions.
Most often, yes. Once the second hard drive fails, the RAID array will stop. However, the data you want is still intact because the stripe sets that hold this information remain on each member. The process works as follows: Each of the drives is copied (imaged), the original layout is determined, and then a virtual rebuild takes place; almost always resulting in an almost complete recovery of your data. It's critical that no one forces a rebuild prior to your recovery.
Usually not. While failed rebuilds are the most common problem we see, and they do cause corruption to your array (usually destroying a portion of the data), they rarely destroy everything. We'll copy each of the disks while they're currently configured, and we'll build your array using these images, bypassing whatever was damaged during the rebuild.
Yes. If your controller or NAS dies, it does not delete any of your data. The data remains on the disks. We'll simply connect those disks into our system and rebuild your array using software, regardless of what hardware has failed. Therefore, you don't have to replace exactly the same controller to be able to retrieve your data.
Please send us all of them, in order if possible. In a RAID configuration, data is striped across every single disk within the array. To be able to rebuild the entire array we will need every disk, even ones that have failed. Label and number each disk by its position in the bay when you ship them.
Our RAID recovery services begin at £500 + VAT, for a simple RAID 1 mirror setup and for multiple disk setups (RAID 5, RAID 6, RAID 10, RAID 50 and RAID 60) alike, and we quote each case individually after the free diagnostic. In most cases you will only pay if we recover your data. Where parts and/or bench time are required to physically repair failing disks, we request a deposit against which parts and/or bench charges are deducted, and the balance is only paid upon successful completion of service.
Yes, on most jobs you would only pay if we recover your data. However, there are some exceptions. For example, when repairing damaged disks individually a deposit may be taken to cover the cost of new parts and labour. Should we fail to recover your data then the balance would not be charged. Prior to starting work on any job, we clearly identify whether or not a deposit will apply.
RAID 0, 1, 5, 6, 10, 50, 60, JBOD, and many other types of RAID configurations using motherboards, and/or various types of hardware including Dell PERC, HP Smart Array, LSI, Adaptec, Areca and Broadcom controllers are all supported. Additionally, motherboard and software RAID like mdadm and Storage Spaces are also supported.
Yes. A NAS is simply a RAID configuration that has a file system layered on top. We support recovery for all RAID configurations on all NAS devices available today (e.g., Synology SHR & Btrfs; QNAP; NETGEAR; Buffalo and others). After recovering the RAID configuration from images of the original disks, we will restore access to your file shares by repairing the file system.
Yes. In addition to restoring access to your RAID volumes containing your shares, once we have recovered your RAID array, we can typically recover VMware or Hyper-V virtual machines stored on the RAID array, SQL and Exchange databases located on the RAID array, and any files stored on the RAID volume, and repair them where damaged. Many of our RAID recoveries involve just these kinds of issues.
Most RAID recoveries will require approximately 5 to 10 working days based upon the number and total capacity of disks requiring recovery and/or repair. Typically, the initial diagnosis is completed within 48 hours. Depending upon the specifics of your case, we may be able to expedite the recovery process if it is an urgent matter related to your business.
Drop-offs at our facility in Cromac Square Monday to Friday from 9am until 5:30pm or insured shipping via postal service both work well. When dropping off your disks please mark the front of each disk with the corresponding slot number(s), package the individual disks separately to prevent damage during transit, and include a contact note with your name and contact information. Unless specifically stated otherwise in advance by us, you may keep the controller or enclosure associated with the disks dropped-off with us. Upon receipt of your media set, we will document the media received into our database, perform diagnostics free-of-charge and provide written confirmation of costs prior to commencing any type of data recovery.
Typically, yes, as long as nothing is forced. RAID 0 does not have redundancy, therefore when one of the members fails, the array will stop working; however, the data still remains split among the drives. Recovery involves making an image of each member drive, restoring the failed drive to a condition that allows for reading on the workbench, and then virtually reconstructing the stripe set. What eliminates this option is initialising the array again or utilising the drives before creating images of them.
Free diagnostics, a fixed price (written), beginning at £500 + VAT, and in most cases you only incur costs if we recover your data. All RAID levels are recovered internally within Belfast. Do not attempt to rebuild. Power off and ship us the disks.